<!doctype html><html lang="en"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width,initial-scale=1"><meta http-equiv="X-UA-Compatible" content="ie=edge"><title>The web accessibility basics - Marco&#39;s Accessibility Blog</title><link rel="canonical" href="https://www.marcozehe.de/the-web-accessibility-basics/"><meta property="og:site_name" content="Marco&#39;s Accessibility Blog"><meta property="og:title" content="The web accessibility basics - Marco&#39;s Accessibility Blog"><meta property="og:type" content="website"><meta property="og:url" content="https://www.marcozehe.de/the-web-accessibility-basics/"><link rel="me" href="https://toot.cafe/@MarcoZehe"><link rel="me" href="https://twitter.com/MarcoInEnglish"><meta name="google-site-verification" content="U0-WV-RvXgwmA_aM2_Box67ZGq4ajoSWe_yrhBjCalM"><meta name="msvalidate.01" content="C91AA90D9939680503E65F4A901ACF61"><link rel="alternate" type="application/rss+xml" href="https://www.marcozehe.de/rss.xml"><style>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</style><link rel="stylesheet" media="print" href="/fonts/fonts.css?87a3-baff-b213" onload="this.media='all'"></head><body><a class="[ skip-link ] [ button ]" href="#main-content">Skip to content</a><header role="banner" class="site-head"><div class="wrapper"><div class="site-head__inner"><a href="/" aria-label="Marco&#39;s Accessibility Blog - Home" class="site-head__brand"><img src="/images/marcos_kopp_100x100.jpg" alt="Head shot of Marco Zehe"></a><nav class="[ nav ] [ site-head__nav ] [ font-sans ]" aria-label="Primary"><ul class="nav__list"><li><a href="/">Home</a></li><li><a href="/about/">About</a></li><li><a href="/articles/">Articles</a></li><li><a href="/blogroll/">Blog Roll</a></li><li><a href="/contact/">Contact</a></li></ul></nav></div></div></header><main tabindex="-1" id="main-content"><article><div class="[ page-header ] [ bg-light-glare ]"><div class="[ wrapper ] [ flow ]"><h1 class="[ page-header__heading ] [ headline ]" data-highlight="primary">The web accessibility basics</h1><div class="[ page-header__summary ] [ measure-long ]"><time datetime="2015-12-14T16:02:40.000Z">14th of December 2015</time><p class="visually-hidden" id="tags-desc">This post has been tagged with</p><ul class="tags-list" aria-describedby="tags-desc"><li><a href="/tag/alttext/">#Alttext</a></li><li><a href="/tag/colorcontrast/">#Colorcontrast</a></li><li><a href="/tag/formlabeling/">#Formlabeling</a></li><li><a href="/tag/graphics/">#Graphics</a></li><li><a href="/tag/html/">#Html</a></li><li><a href="/tag/htmlaccessibility/">#Htmlaccessibility</a></li><li><a href="/tag/wcag/">#Wcag</a></li><li><a href="/tag/websemantics/">#Websemantics</a></li><li><a href="/tag/webstandards/">#Webstandards</a></li></ul></div></div></div><div class="[ page-content ] [ flow wrapper ] [ flow-space-700 gap-top-700 ]"><p>I’ve been asked again and again over the years what the absolute basics of web accessibility are. And while I always thought that it is not so difficult to find resources about these basics, the recurrence of that question prompted me to finally write my own take on this topic. So here it is, my list of absolute web accessibility basics every web developer should know about.</p><h2 id="alternative-text-for-images">Alternative text for images <a class="header-anchor" href="#alternative-text-for-images">&#128279;</a></h2><p>One of the questions I get asked the most is “which graphics require alternative text”? The answer to this question has three parts:</p><ol><li><em>All</em><a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/img">img</a> tags require an alt attribute. This goes <em>without exception</em>. Everything else is an error. If you have an img tag in your HTML without an alt attribute, add it <strong>now</strong>.</li><li>Every alt attribute has to have a value. And here is where it gets interesting. If the image is important, because it is part of an <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/a">a</a> tag, for example, it has to have meaningful text. What is a best alt text is still a point of sometimes heated debate, but the guideline is to use best judgement. Describe the image briefly, but avoid the phrase “image of” or “graphic of”. Because screen readers already know it is a graphic. In addition, every image that adds context to the text of a page that is important in understanding the text needs to have meaningful alternative text. If, on the other hand, an image is purely decorative, its alternative text consists of an empty string “”. That is simply alt=””, two consecutive quotes. But the alt attribute <em>has</em> to be there even for these decorative images, it must not be omitted.</li><li>It is called alt attribute, alternative text, but never alt tag. alt is an attribute, not a HTML tag.</li></ol><p>All the above also applies to SVG graphics. And if you’re really modern and use the <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/picture">picture</a> element, the rules apply there, too.</p><p>Using proper alternative text does not just help blind and low vision screen reader users. It also helps on mobile where images sometimes cannot be loaded, for example over slow connections. So by implementing proper alternative text, you help many more people than you might initially imagine.</p><h2 id="labeling-form-fields">Labeling form fields <a class="header-anchor" href="#labeling-form-fields">&#128279;</a></h2><p>Another very common question I get, and a very common error I see on many many web pages even in 2015, concerns the labeling of forms and form fields. In fact, when dealing with many web developers, I am surprised that many don’t even seem to be aware that there is a <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/label">label</a> element, for example. So here are the most common rules about form field accessibility:</p><ol><li>Most <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input">input</a> elements, as well as the <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/select">select</a> and <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/textarea">textarea</a> elements, need an associated label element that states the purpose. The one exception are those that produce a button, like the types of button, reset, and submit do. But every other, be it text, checkbox, password, radio (button), search etc. require a label element to be present.</li><li>The association between such an input and label happens by giving the input a unique ID, given by the id attribute on the input, and the label’s for attribute, which points to said ID. To test that your label actually works, click on the label, not the input, select or textarea. Does the said element still get focus? If so, you did things right. This increases the click target for many audiences, including mobile devices where bigger touch targets are always advantageous. And it associates the label text to the input for screen readers unambiguously. Do <strong>not</strong>, under <strong>any</strong> circumstances, use the placeholder attribute as the label for an input element! <a href="https://www.paciellogroup.com/blog/2011/02/html5-accessibility-chops-the-placeholder-attribute/">Read here, why</a>.</li><li>Give <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/button">button</a> elements inner text, or if it needs to be a graphic, label it properly with alt text that corresponds to what a textual button label would be. See the section on alternative text for images above. Also, as recommended in the MDN article linked to, prefer button elements over html:input type=”button”, because it is more flexible for styling. Also, this is <strong>the</strong> go-to element if you have anything that is a div or span and that you want to make clickable with hundreds of kilobytes of JavaScript code. So before you do that, use button instead.</li><li>A series of radio buttons go inside a <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/fieldset">fieldset</a> element to group them together. The first element inside this fieldset is the <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/legend">legend</a> element that contains the over-arching question or label for this group of choices.</li><li>Fieldset and Legend should also be used if grouping together different sections of a bigger form for better readability. The fieldset element can take more than just radio button inputs.</li><li>Label required fields by providing the HTML5 required attribute on the input as well as stating in the label that a form field is required. This can be done by either providing the word “required” as part of the label, or putting explanatory text at the <em>top</em> of the form telling users that fields marked with an asterisk are required. Do not denote required fields only by a different color. Screen reader users won’t be able to recognize those, and color-blind users, which are 8 percent of the worldwide male population, will also have a hard time finding these.</li><li>Use appropriate input types for e-mail, URL, phone number etc. Mobile users will thank you because these will bring up the correct keyboards for the information asked. Also, it will make evaluation easier for you because the browser will immediately know if the correct information, e. g. a valid e-mail address, was entered. Modern browsers will do that, and if you need to support older browsers, they’ll automatically fall back to text, which is an appropriate fall-back.</li><li>Make sure keyboard visibility is always guaranteed. If you see a frame appear around a form field when you click inside it, you should also see it appear when you walk through your form using the tab key on your keyboard. If it does not apear, check your :focus and :active stylings for these form fields in your CSS.</li></ol><p>If you need something a little more fancy-looking, please <em>do not</em> fall back to using clickable span and div elements. Because if you do that, you’ll have to add roles, state handling, keyboard focusability and acting on key presses all by yourself. If you use form elements and help yourself with some span elements for styling inside the label, for example, you will get all the accessibility for free, including keyboard, screen readers etc.</p><h2 id="document-structure">Document structure <a class="header-anchor" href="#document-structure">&#128279;</a></h2><p>Believe it or not, but at its core, the web is a document-based structure. So even when we create fancy web applications such as Gmail, the heart of it is a document. And there is a lot you can do with documents semantically that will get you usually 80 to 90 percent of the accessibility for free. For example:</p><h3 id="heading-structure">Heading structure <a class="header-anchor" href="#heading-structure">&#128279;</a></h3><p>Noticed the different headings and sub headings in this blog post? Well, there are elements for that. They are called <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/Heading_Elements">heading elements</a>. And they give you exactly that, a six level heading structure to denote a main heading, secondary sub headings, and sub headings to those for sub sections, like this one, for example. This gives your document a logical, easy to follow structure. Have you ever wondered how Wikipedia puts together its table of contents for each article? They use the logical heading structure for that, too!The h1 through h6 elements are unambiguous in telling screen readers, search engines and other technologies what the structure of your document is. Do not mix unless the structure requires it, do not skip levels if possible, since that will disrupt the logic. And never ever again use something like a div with a class of “heading1” in your code. Screen readers, search engines, and other technologies will not know what to do with those. They will know how to treat your headings properly, though!</p><h3 id="landmarks">Landmarks <a class="header-anchor" href="#landmarks">&#128279;</a></h3><p>There are some more ways to structure your document’s contents. By landmarks, for example. Landmarks can be <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/article">article</a>, <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/aside">aside</a>, <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/footer">footer</a>, <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/header">header</a>, <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/nav">nav</a> and <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/main">main</a>. Adding such landmarks appropriately can help further provide sense to your document and help users more easily navigate it.</p><h3 id="lists">Lists <a class="header-anchor" href="#lists">&#128279;</a></h3><p>HTML knows a whole bunch about lists. There are <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/ul">unordered</a> and <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/ol">ordered</a> lists that are exactly what you’d expect them to be. You can add numbering schemes, even nest them, and the browser will do the rest for you. You can style them the way you want them to look in CSS and thus provide even more structure and meaning to your document’s content. You’ve already seen ordered (numbered) lists in this blog post.</p><p>There is also a list type for definition term and explanation groups. The MDN page on the <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/dl">dl</a> element has some great examples of use.</p><h3 id="others">Others <a class="header-anchor" href="#others">&#128279;</a></h3><p>Did you know that HTML has an element to denote paragraphs? It is called the <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/p">p</a> element. For long citations that require their own paragraphs, use <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/blockquote">blockquote</a>. For short, inline, quotes, use the <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/q">q</a> element. Visual separators can be inserted via the <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/hr">hr</a> element.</p><p>For all these elements, use CSS to define indentation, separation between paragraphs etc. Those will not impact the semantics, but you are then free to adjust the visuals to your liking or your client’s requirements.</p><h2 id="tables">Tables <a class="header-anchor" href="#tables">&#128279;</a></h2><p>Tables are its own special case. So much can go wrong, and historically, so much abuse has happened to this poor <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/table">table</a> element and its sub elements! Especially layouts were done for a long time using tables, before HTML 4 and the onset of CSS. But I still find in modern web applications in 2015, cases where layout tables are being used to align form fields and their labels to one another. <em>STOP DOING THAT</em>! <strong>PLEASE</strong>!</p><p>The table element is a very useful element for creating data representations. Product detail listings, price lists etc. Also, shopping carts with quantities, sub totals and totals, and many other structured data collections can, and should, be put into data tables. Here are some tips to help you:</p><ol><li>Add a <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/caption">caption</a> element to give the table a proper heading or summary.</li><li>Use <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/th">th</a> elements to denote column and row headings. Make use of their scope and other attributes to clearly associate what belongs to which.</li><li>Use other structural table elements denoted in the “see also” section of the table element documentation to further structure your table.</li><li>If a table gets too complex or has multiple sections that don’t necessarily have to be in one table, split them up into several data tables.</li></ol><p>For more information, I’d like to refer you to the friends at WebAIM who have put together a very good two-pager on the <a href="http://webaim.org/techniques/tables/">accessibility of HTML tables</a>.</p><h2 id="some-more-quickies">Some more quickies <a class="header-anchor" href="#some-more-quickies">&#128279;</a></h2><p>Here are some more things you can quickly check and make sure when you write HTML, CSS and JavaScript.</p><h3 id="separation-of-concepts">Separation of concepts <a class="header-anchor" href="#separation-of-concepts">&#128279;</a></h3><p>HTML defines your content structure. It is what screen readers and other assistive technologies use to represent your content to their users.</p><p>CSS defines how that content looks visually. Its positioning, indentation, padding, margins usually have no bearing on what screen readers render to the user, with one exception: If display: none; or visibility: hidden; styles are used, that content will also not be available to assistive technologies. See my post titled “<a href="https://www.marcozehe.de/2012/04/24/hiding-content-untangled-hiding-vs-moving-out-of-the-visible-viewport/">Hiding content untagled</a>” for more information.</p><p>Also, CSS :before and :after text is rendered to assistive technologies. So be aware what you put in there.</p><p>JavaScript adds dynamic functionality. Its output must be proper HTML and CSS, too, if it manipulates the DOM. JavaScript dynamics in itself are no problem to accessibility, only some specific behaviors can be, like losing keyboard focus.</p><p>The clearer you separate the three, the more maintainable your code will be. Put CSS in their own files, don’t embed it in the HTML. Put JS modules in their files and don’t embed JS code in your HTML, either. This will make everything more readable, and remind you that the concepts should really be separate that just happen to work together rather than mingling uncontrollably.</p><h3 id="color-contrast">Color contrast <a class="header-anchor" href="#color-contrast">&#128279;</a></h3><p>Have you ever stood in the sunlight or another bright light source with your smartphone or tablet in hand and wondered why you couldn’t read something? Well, you were suffering from a lack of contrast between foreground and background on the page you were visiting. Low contrast ratios lead to bad readability in bright light situations. For the aging population, as well as low-vision users, low contrasts pose an even greater obstacle in readability. The Web Content Accessibility Guidelines define as a success criteria to have a <a href="http://www.w3.org/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-contrast.html">contrast ratio of 4.5:1</a> on main content text to its background. You can use tools like the <a href="https://www.paciellogroup.com/resources/contrastanalyser/">Colour Contrast Analyser</a> to point at your content and see whether your visuals meet this requirement. Even if you’re not auditing for WCAG compliance, adhering to this rule of thumb is still a good idea for your own eyes as well as everyone else’s.</p><h3 id="keep-pinch-alive">Keep Pinch alive <a class="header-anchor" href="#keep-pinch-alive">&#128279;</a></h3><p>When you develop for the mobile web, and today it is most likely you are, please <a href="http://www.iheni.com/mobile-accessibility-tip-dont-suppress-pinch-zoom/">keep the Pinch To Zoom gesture alive</a>! Do not disable this gesture vital to many more of your readers than you might think! Pinching to zoom something small on a web page is very common and does not apply only to aging readers as well as those with low vision. If your layout does not cope with the pinch gesture for some reason, you need to revisit your responsive design and fix it. Do <em>not</em> disable the pinch gesture on mobile browsers!</p><h2 id="ok%2C-but-what-about-advanced-widgets%3F">OK, but what about advanced widgets? <a class="header-anchor" href="#ok%2C-but-what-about-advanced-widgets%3F">&#128279;</a></h2><p>If you really need to implement advanced widgets that are not indiginous to HTML, take good care that you implement all aspects of them. I have some information on how to make <a href="https://www.marcozehe.de/2013/04/24/easy-aria-tip-6-making-clickables-accessible/">clickable widgets that should be buttons or links</a>, <a href="https://www.marcozehe.de/2013/02/02/advanced-aria-tip-1-tabs-in-web-apps/">tabs and tabpanels</a>, <a href="https://www.marcozehe.de/2014/03/11/easy-aria-tip-7-use-listbox-and-option-roles-when-constructing-autocomplete-lists/">some auto-complete widgets</a> and <a href="https://www.marcozehe.de/2015/02/05/advanced-aria-tip-2-accessible-modal-dialogs/">modal dialogs</a> accessible. The friends at SSB Bart Group have a quite current post on <a href="http://www.ssbbartgroup.com/blog/creating-an-accessible-aria-tree-control/">ARIA tree views</a> up, and Terrill Thompson conducted an extensive test of <a href="http://terrillthompson.com/blog/474">ARIA menus</a>.</p><h2 id="it-is-all-in-the-semantics">It is all in the semantics <a class="header-anchor" href="#it-is-all-in-the-semantics">&#128279;</a></h2><p>As you may have guessed by now, adhering to semantic structures that HTML already offers today will get you a long long way towards accessible web content. In fact, most web content that doesn’t need special widgets will most probably be over 90% accessible by just using proper semantics and honoring a few extras that are in styling.</p><p>Only if you need to use widgets that are not provided by HTML, will you really have to dig deeper and dive into standards like <a href="https://www.marcozehe.de/2014/03/27/what-is-wai-aria-what-does-it-do-for-me-and-what-not/">WAI-ARIA</a>. But even its first rule is: Don’t use it if you don’t have to! Just sugar-coating everything with WAI-ARIA attributes you find in Google somewhere will do more harm than good. I promise!</p><h2 id="in-conclusion">In conclusion <a class="header-anchor" href="#in-conclusion">&#128279;</a></h2><p>If there’s one wish I have for Christmas from the web developer community at large, it is this: Be good citizens of the web, and learn <em>proper</em> HTML before you even so much as touch any JavaScript framework. Those frameworks are great and offer a lot of features, no doubt. But before you use hundreds of kilobytes of JavaScript to make something clickable, you may want to try if a simple button element doesn’t do the trick just as fine!</p><p>Use semantics and save yourselves a lot of extra work, because all the standard elements come with accessibility for free.</p><p>Teach others! If you’ve mastered the skills of a good HTML and CSS citizen, teach others! Get involved, contribute your knowledge and share your wisdom! You’ll help at least two more than the obvious ones with every contribution you make!</p><p>I hope this article helps a little to clarify how easy it is to gain way over 80%, if not over 90% of accessible web content just by following standards and semantics! Please feel free to share your thoughts in the comments below, and if there is something I missed that you think should belong in this collection, feel free to also let me know, and I’ll add it!</p><p>Thank you!</p><p>This topic is also available as a <a href="https://www.youtube.com/watch?v=zngSYz3pYl4&amp;list=PL95LOQw9SLWxmcZtzBiFuT9HAJKFJnl2n&amp;index=9">video presentation</a> held at the 2016 Global Accessibility Awareness Day’s Inclusive Design 24 event.</p></div><footer class="recommended-posts"><div class="[ wrapper ] [ flow flow-space-700 ]" id="post-list"><h2 class="[ headline ] [ measure-micro ]" data-highlight="primary">More from this blog</h2><div class="[ post-list ] [ flow ]"><div class="[ post-list__item ]"><h3 class="[ headline leading-tight measure-long ]"><a href="/firefox-49-supports-the-html5-details-and-summary-elements/" class="post-list__link">Firefox 49 supports the HTML5 and elements</a></h3><p class="post-summary">As you may or may not have heard, <a href="https://developer.mozilla.org/de/Firefox/Releases/49">Firefox 49</a> supports the HTML5 &lt;<a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/details">details</a>&gt; and &lt;<a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/summary">summary</a>&gt; elements. Both full keyboard support and support for assistive technologies is also available right from the start.</p><p class="post-list__tags">tagged with: <span><a href="/tag/details/">#Details</a>, <a href="/tag/html5/">#Html5</a>, <a href="/tag/summary/">#Summary</a></span></p></div><div class="[ post-list__item ]"><h3 class="[ headline leading-tight measure-long ]"><a href="/aria-in-gmail-2-enhancing-the-chat-experience/" class="post-list__link">ARIA in Gmail #2: Enhancing the Chat experience</a></h3><p class="post-summary">This post continues a series on the implementation of <a href="http://developer.mozilla.org/en/docs/Accessible_DHTML">ARIA (Accessible Rich Internet Applications)</a> in <a href="http://mail.google.com/">Gmail</a>.</p><p class="post-list__tags">tagged with: <span></span></p></div><div class="[ post-list__item ]"><h3 class="[ headline leading-tight measure-long ]"><a href="/nvda-2019-3-beta-1-is-available/" class="post-list__link">NVDA 2019.3 Beta 1 is available</a></h3><p class="post-summary">NVDA 2019.3 beta 1 has been <a href="https://www.nvaccess.org/post/nvda-2019-3beta1-now-available-for-testing/">released today</a>. It is a huge milestone in the history of this free and open-source screen reader.</p><p class="post-list__tags">tagged with: <span><a href="/tag/nvdasr/">#Nvdasr</a></span></p></div></div></div></footer></article></main><div class="wrapper"><aside class="buy-me-a-coffee"><h2 class="buy-me-a-coffee__headline">Do you appreciate my content?</h2><p>If you'd like to show your appreciation for my content because it may have helped you in some way or you just liked it, you can buy me a hot beverage with the below PayPal button. It's safe and secure, and I'll be very grateful.</p><form action="https://www.paypal.com/donate" method="post" target="_top"><input type="hidden" name="hosted_button_id" value="BL3P9BB77K2UC"> <input type="image" src="https://www.paypalobjects.com/en_US/DK/i/btn/btn_donateCC_LG.gif" border="0" name="submit" title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button"> <img alt="" border="0" src="https://www.paypal.com/en_DE/i/scr/pixel.gif" width="1" height="1"></form></aside></div><footer class="site-footer" role="contentinfo"><div class="wrapper"><p>Copyright &copy; 2021 Marco Zehe. Design provided by <a lang="de" href="https://www.grochtdreis.de">Jens Grochtdreis</a>. Built with <a href="https://www.11ty.dev">Eleventy</a> and hosted on <a href="https://www.netlify.com/">Netlify</a>.</p><p><a href="/site-notice/">Site notice</a> – <a href="/privacy-policy/">Privacy policy</a> – <a href="/rss.xml">Follow posts via RSS</a></p></div></footer></body></html>