<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="https://www.marcozehe.de/xmlrpc.php">
		<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>Firefox 57 from an NVDA user&#039;s perspective - Marco&#039;s Accessibility Blog</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v4.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Firefox 57 from an NVDA user&#039;s perspective - Marco&#039;s Accessibility Blog" />
<meta property="og:description" content="Firefox 57, also known as Firefox Quantum, will be released on November 14. It will bring some significant changes to the Firefox rendering engine to improve performance and open the door for more new features in the future. Here is what you need to know if you are a user of the NVDA screen reader. &hellip; Continue reading &quot;Firefox 57 from an NVDA user&#8217;s perspective&quot;" />
<meta property="og:url" content="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/" />
<meta property="og:site_name" content="Marco&#039;s Accessibility Blog" />
<meta property="article:publisher" content="https://facebook.com/marco.zehe.hamburg" />
<meta property="article:tag" content="Accessibility" />
<meta property="article:tag" content="Firefox" />
<meta property="article:tag" content="NVDA" />
<meta property="article:tag" content="Quantum" />
<meta property="article:section" content="Accessibility" />
<meta property="article:published_time" content="2017-11-07T15:57:28+01:00" />
<meta property="article:modified_time" content="2017-11-07T15:58:00+01:00" />
<meta property="og:updated_time" content="2017-11-07T15:58:00+01:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Firefox 57, also known as Firefox Quantum, will be released on November 14. It will bring some significant changes to the Firefox rendering engine to improve performance and open the door for more new features in the future. Here is what you need to know if you are a user of the NVDA screen reader. &hellip; Continue reading &quot;Firefox 57 from an NVDA user&#8217;s perspective&quot;" />
<meta name="twitter:title" content="Firefox 57 from an NVDA user&#039;s perspective - Marco&#039;s Accessibility Blog" />
<meta name="twitter:site" content="@MarcoInEnglish" />
<meta name="twitter:creator" content="@MarcoInEnglish" />
<meta property="DC.date.issued" content="2017-11-07T15:57:28+01:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Marco&#039;s Accessibility Blog &raquo; Feed" href="https://www.marcozehe.de/feed/" />
<link rel="alternate" type="application/rss+xml" title="Marco&#039;s Accessibility Blog &raquo; Comments Feed" href="https://www.marcozehe.de/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Marco&#039;s Accessibility Blog &raquo; Firefox 57 from an NVDA user&#8217;s perspective Comments Feed" href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.marcozehe.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='twentysixteen-jetpack-css'  href='https://www.marcozehe.de/wp-content/plugins/jetpack/modules/theme-tools/compat/twentysixteen.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CMontserrat%3A400%2C700%7CInconsolata%3A400&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://www.marcozehe.de/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-style-css'  href='https://www.marcozehe.de/wp-content/themes/twentysixteen/style.css?ver=4.8.3' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='twentysixteen-ie-css'  href='https://www.marcozehe.de/wp-content/themes/twentysixteen/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentysixteen-ie8-css'  href='https://www.marcozehe.de/wp-content/themes/twentysixteen/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentysixteen-ie7-css'  href='https://www.marcozehe.de/wp-content/themes/twentysixteen/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.marcozehe.de/wp-content/plugins/jetpack/css/jetpack.css?ver=5.4' type='text/css' media='all' />
<script type='text/javascript' src='https://www.marcozehe.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.marcozehe.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.marcozehe.de/wp-content/themes/twentysixteen/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.marcozehe.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.marcozehe.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.marcozehe.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.3" />
<link rel='shortlink' href='https://wp.me/phVQk-dJ' />
<link rel="alternate" type="application/json+oembed" href="https://www.marcozehe.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.marcozehe.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		</head>

<body class="post-template-default single single-post postid-851 single-format-standard">
<div id="page" class="site">
	<div class="site-inner">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		<header id="masthead" class="site-header" role="banner">
			<div class="site-header-main">
				<div class="site-branding">
					
											<p class="site-title"><a href="https://www.marcozehe.de/" rel="home">Marco&#039;s Accessibility Blog</a></p>
											<p class="site-description">Helping to make accessibility accessible on the web and elsewhere</p>
									</div><!-- .site-branding -->

									<button id="menu-toggle" class="menu-toggle">Menu</button>

					<div id="site-header-menu" class="site-header-menu">
													<nav id="site-navigation" class="main-navigation" role="navigation" aria-label="Primary Menu">
								<div class="menu-main-menu-container"><ul id="menu-main-menu" class="primary-menu"><li id="menu-item-789" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-789"><a href="https://www.marcozehe.de/category/firefox/">Firefox</a></li>
<li id="menu-item-790" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-790"><a href="https://www.marcozehe.de/category/aria/">ARIA</a></li>
<li id="menu-item-791" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-791"><a href="https://www.marcozehe.de/category/mozilla/">Mozilla</a></li>
<li id="menu-item-792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-792"><a href="https://www.marcozehe.de/category/mobile/">Mobile</a></li>
<li id="menu-item-793" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-793"><a href="https://www.marcozehe.de/category/apple/">Apple</a></li>
<li id="menu-item-794" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-794"><a href="https://www.marcozehe.de/category/nvda/">NVDA</a></li>
<li id="menu-item-795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-795"><a href="https://www.marcozehe.de/web-accessibility-resources/">Web Accessibility Resources</a></li>
<li id="menu-item-796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-796"><a href="https://www.marcozehe.de/articles/how-to-use-nvda-and-firefox-to-test-your-web-pages-for-accessibility/">How to use NVDA and Firefox to test your web pages for accessibility</a></li>
<li id="menu-item-797" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-797"><a href="https://www.marcozehe.de/about/">About</a></li>
</ul></div>							</nav><!-- .main-navigation -->
						
											</div><!-- .site-header-menu -->
							</div><!-- .site-header-main -->

					</header><!-- .site-header -->

		<div id="content" class="site-content">

<div id="primary" class="content-area">
	<main id="main" class="site-main" role="main">
		
<article id="post-851" class="post-851 post type-post status-publish format-standard hentry category-accessibility category-firefox category-nvda tag-accessibility tag-firefox tag-nvda tag-quantum">
	<header class="entry-header">
		<h1 class="entry-title">Firefox 57 from an NVDA user&#8217;s perspective</h1>	</header><!-- .entry-header -->

	
	
	<div class="entry-content">
		<p>Firefox 57, also known as Firefox Quantum, will be released on November 14. It will bring some significant changes to the Firefox rendering engine to improve performance and open the door for more new features in the future. Here is what you need to know if you are a user of the NVDA screen reader.<span id="more-851"></span></p>
<p>For users of the NVDA screen reader, some of these changes may initially seem like a step backward. To make the accessibility features work with the new architecture, we had to make some significant changes which will initially feel less performant than before. Especially complex pages and web applications such as Facebook or Gmail will feel slower to NVDA users in this Firefox release.</p>
<h2>Improvements in the pipeline</h2>
<p>Fortunately, NVDA users will only have to put up with these slowdowns for one Firefox release. Firefox 58, which will move to beta the moment Firefox 57 is being released, will already improve performance so significantly that most smaller pages will feel as snappy as before, larger pages will take a lot less time to be loaded into NVDA’s browse mode buffer, and web applications such as Gmail or Facebook will feel more fluid.</p>
<p>And we’re not stopping there. In Firefox Nightly, then on version 59, performance improvements will continue, and more big pages and web applications should return to a normal working speed with NVDA.</p>
<h2>I need full speed</h2>
<p>If you <em>do</em> require Firefox to perform as fast as before and cannot or do not want to wait until the above mentioned performance improvements arrive on your machine, you have the option to <a href="https://www.mozilla.org/en-US/firefox/organizations/faq/">switch to the Extended Support Release (ESR)</a>, which is on version 52 and will receive security fixes until long into 2018.</p>
<p>However, we encourage you to stick with us on the current release if you possibly can. Your findings, if you choose to report them to us, will greatly help us improve Firefox further even faster, because even we might not think of all the scenarios that might be day to day sites for you.</p>
<h2>I want to stick with you. How can I help?</h2>
<p>That’s great! If you encounter any big problems, like pages that take unusually long to load, we want to know about them. We already know that long Wikipedia articles such as the one about <a href="https://en.wikipedia.org/wiki/World_War_I">World War I</a> will take about 12 seconds to load on an average Windows 10 machine and a current NVDA release. In Firefox 58 beta, we will have brought this down to less than 8 seconds already, and the goal is to bring that time down even further. So if you really want to help, you can choose to <a href="https://www.mozilla.org/en-GB/firefox/channel/desktop/">upgrade to our beta channel</a> and re-test the problem you encountered there. If it is already improved, you can be certain we’re on top of the underlying problem. If not, we <a href="https://bugzilla.mozilla.org/">definitely want to know</a> where you found the problem and what steps led to it.</p>
<p>And if you really want to be on the bleeding edge, getting the latest fixes literally hours or days after they landed in our source code, you can choose to <a href="https://nightly.mozilla.org/">update to our Firefox Nightly channel</a>, and get new builds of Firefox twice a day. There, if you encounter problems like long lags, or even crashes, they will be very closely tied to what we were recently working on, and we will be able to resolve the problems quickly, before they even hit the next beta cycle.</p>
<h2>In conclusion</h2>
<p>We know we’re asking a lot of you since you’ve always had a very fast and efficient browsing experience when you used Firefox in combination with NVDA. And we are truly sorry that we’ll have to temporarily slip here. But rest assured that we’re working hard with the full team to kick Firefox back into gear so that each followup release will bring us back closer to where we were before 57, plus the added benefits Quantum brings for all users.</p>
<h2>More information</h2>
<ul>
<li><a href="https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem">Reporting a performance problem</a>, including keyboard shortcuts and further instructions on reporting.</li>
<li><a href="https://support.mozilla.org/en-US/kb/can-i-use-my-screen-reader-new-firefox">Can I use my screen reader with the new Firefox?</a> &#8211; Mozilla support article with more general screen reader compatibility information.</li>
</ul>
<div class="shariff shariff-main shariff-align-flex-start shariff-widget-align-flex-start" data-services="twitter%7Cfacebook%7Cgoogleplus%7Cpocket%7Clinkedin%7Cxing" data-url="https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" data-timestamp="1510070280" data-hidezero="1" data-backendurl="https://www.marcozehe.de/wp-json/shariff/v1/share_counts?"><div class="ShariffHeadline"><h3 class="shariff-headline">Share this post</h3></div><ul class="shariff-buttons theme-default orientation-horizontal buttonsize-medium"><li class="shariff-button twitter" style="background-color:#32bbf5"><a href="https://twitter.com/share?url=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F&text=Firefox+57+from+an+NVDA+user%E2%80%99s+perspective&via=MarcoInEnglish" title="Share on Twitter" aria-label="Share on Twitter" role="button" rel="noopener nofollow" class="shariff-link" target="_blank" style="background-color:#55acee; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 32"><path d="M29.7 6.8q-1.2 1.8-3 3.1 0 0.3 0 0.8 0 2.5-0.7 4.9t-2.2 4.7-3.5 4-4.9 2.8-6.1 1q-5.1 0-9.3-2.7 0.6 0.1 1.5 0.1 4.3 0 7.6-2.6-2-0.1-3.5-1.2t-2.2-3q0.6 0.1 1.1 0.1 0.8 0 1.6-0.2-2.1-0.4-3.5-2.1t-1.4-3.9v-0.1q1.3 0.7 2.8 0.8-1.2-0.8-2-2.2t-0.7-2.9q0-1.7 0.8-3.1 2.3 2.8 5.5 4.5t7 1.9q-0.2-0.7-0.2-1.4 0-2.5 1.8-4.3t4.3-1.8q2.7 0 4.5 1.9 2.1-0.4 3.9-1.5-0.7 2.2-2.7 3.4 1.8-0.2 3.5-0.9z"/></svg></span><span class="shariff-text">tweet</span>&nbsp;<span class="shariff-count" data-service="twitter" style="color:#55acee;opacity:0"></span>&nbsp;</a></li><li class="shariff-button facebook" style="background-color:#4273c8"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" title="Share on Facebook" aria-label="Share on Facebook" role="button" rel="noopener nofollow" class="shariff-link" target="_blank" style="background-color:#3b5998; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 18 32"><path d="M17.1 0.2v4.7h-2.8q-1.5 0-2.1 0.6t-0.5 1.9v3.4h5.2l-0.7 5.3h-4.5v13.6h-5.5v-13.6h-4.5v-5.3h4.5v-3.9q0-3.3 1.9-5.2t5-1.8q2.6 0 4.1 0.2z"/></svg></span><span class="shariff-text">share</span>&nbsp;<span class="shariff-count" data-service="facebook" style="color:#3b5998;opacity:0"></span>&nbsp;</a></li><li class="shariff-button googleplus" style="background-color:#f75b44"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" title="Share on Google+" aria-label="Share on Google+" role="button" rel="noopener nofollow" class="shariff-link" target="_blank" style="background-color:#d34836; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M31.6 14.7h-3.3v-3.3h-2.6v3.3h-3.3v2.6h3.3v3.3h2.6v-3.3h3.3zM10.8 14v4.1h5.7c-0.4 2.4-2.6 4.2-5.7 4.2-3.4 0-6.2-2.9-6.2-6.3s2.8-6.3 6.2-6.3c1.5 0 2.9 0.5 4 1.6v0l2.9-2.9c-1.8-1.7-4.2-2.7-7-2.7-5.8 0-10.4 4.7-10.4 10.4s4.7 10.4 10.4 10.4c6 0 10-4.2 10-10.2 0-0.8-0.1-1.5-0.2-2.2 0 0-9.8 0-9.8 0z"/></svg></span><span class="shariff-text">share</span>&nbsp;<span class="shariff-count" data-service="googleplus" style="color:#d34836;opacity:0"></span>&nbsp;</a></li><li class="shariff-button threema shariff-mobile" style="background-color:#4fbc24"><a href="threema://compose?text=Firefox+57+from+an+NVDA+user%E2%80%99s+perspective%20https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" title="Share on Threema" aria-label="Share on Threema" role="button" rel="nofollow" class="shariff-link" target="_blank" style="background-color:#1f1f1f; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M30.8 10.9c-0.3-1.4-0.9-2.6-1.8-3.8-2-2.6-5.5-4.5-9.4-5.2-1.3-0.2-1.9-0.3-3.5-0.3s-2.2 0-3.5 0.3c-4 0.7-7.4 2.6-9.4 5.2-0.9 1.2-1.5 2.4-1.8 3.8-0.1 0.5-0.2 1.2-0.2 1.6 0 0.4 0.1 1.1 0.2 1.6 0.4 1.9 1.3 3.4 2.9 5 0.8 0.8 0.8 0.8 0.7 1.3 0 0.6-0.5 1.6-1.7 3.6-0.3 0.5-0.5 0.9-0.5 0.9 0 0.1 0.1 0.1 0.5 0 0.8-0.2 2.3-0.6 5.6-1.6 1.1-0.3 1.3-0.4 2.3-0.4 0.8 0 1.1 0 2.3 0.2 1.5 0.2 3.5 0.2 4.9 0 5.1-0.6 9.3-2.9 11.4-6.3 0.5-0.9 0.9-1.8 1.1-2.8 0.1-0.5 0.2-1.1 0.2-1.6 0-0.7-0.1-1.1-0.2-1.6-0.3-1.4 0.1 0.5 0 0zM20.6 17.3c0 0.4-0.4 0.8-0.8 0.8h-7.7c-0.4 0-0.8-0.4-0.8-0.8v-4.6c0-0.4 0.4-0.8 0.8-0.8h0.2l0-1.6c0-0.9 0-1.8 0.1-2 0.1-0.6 0.6-1.2 1.1-1.7s1.1-0.7 1.9-0.8c1.8-0.3 3.7 0.7 4.2 2.2 0.1 0.3 0.1 0.7 0.1 2.1v0 1.7h0.1c0.4 0 0.8 0.4 0.8 0.8v4.6zM15.6 7.3c-0.5 0.1-0.8 0.3-1.2 0.6s-0.6 0.8-0.7 1.3c0 0.2 0 0.8 0 1.5l0 1.2h4.6v-1.3c0-1 0-1.4-0.1-1.6-0.3-1.1-1.5-1.9-2.6-1.7zM25.8 28.2c0 1.2-1 2.2-2.1 2.2s-2.1-1-2.1-2.1c0-1.2 1-2.1 2.2-2.1s2.2 1 2.2 2.2zM18.1 28.2c0 1.2-1 2.2-2.1 2.2s-2.1-1-2.1-2.1c0-1.2 1-2.1 2.2-2.1s2.2 1 2.2 2.2zM10.4 28.2c0 1.2-1 2.2-2.1 2.2s-2.1-1-2.1-2.1c0-1.2 1-2.1 2.2-2.1s2.2 1 2.2 2.2z"/></svg></span><span class="shariff-text">share</span>&nbsp;</a></li><li class="shariff-button whatsapp shariff-mobile" style="background-color:#5cbe4a"><a href="whatsapp://send?text=Firefox+57+from+an+NVDA+user%E2%80%99s+perspective%20https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" title="Share on WhatsApp" aria-label="Share on WhatsApp" role="button" rel="nofollow" class="shariff-link" target="_blank" style="background-color:#34af23; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M17.6 17.4q0.2 0 1.7 0.8t1.6 0.9q0 0.1 0 0.3 0 0.6-0.3 1.4-0.3 0.7-1.3 1.2t-1.8 0.5q-1 0-3.4-1.1-1.7-0.8-3-2.1t-2.6-3.3q-1.3-1.9-1.3-3.5v-0.1q0.1-1.6 1.3-2.8 0.4-0.4 0.9-0.4 0.1 0 0.3 0t0.3 0q0.3 0 0.5 0.1t0.3 0.5q0.1 0.4 0.6 1.6t0.4 1.3q0 0.4-0.6 1t-0.6 0.8q0 0.1 0.1 0.3 0.6 1.3 1.8 2.4 1 0.9 2.7 1.8 0.2 0.1 0.4 0.1 0.3 0 1-0.9t0.9-0.9zM14 26.9q2.3 0 4.3-0.9t3.6-2.4 2.4-3.6 0.9-4.3-0.9-4.3-2.4-3.6-3.6-2.4-4.3-0.9-4.3 0.9-3.6 2.4-2.4 3.6-0.9 4.3q0 3.6 2.1 6.6l-1.4 4.2 4.3-1.4q2.8 1.9 6.2 1.9zM14 2.2q2.7 0 5.2 1.1t4.3 2.9 2.9 4.3 1.1 5.2-1.1 5.2-2.9 4.3-4.3 2.9-5.2 1.1q-3.5 0-6.5-1.7l-7.4 2.4 2.4-7.2q-1.9-3.2-1.9-6.9 0-2.7 1.1-5.2t2.9-4.3 4.3-2.9 5.2-1.1z"/></svg></span><span class="shariff-text">share</span>&nbsp;</a></li><li class="shariff-button pocket" style="background-color:#444"><a href="https://getpocket.com/edit?url=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F&title=Firefox+57+from+an+NVDA+user%E2%80%99s+perspective" title="Save to Pocket" aria-label="Save to Pocket" role="button" rel="noopener nofollow" class="shariff-link" target="_blank" style="background-color:#ff0000; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 28"><path d="M24.5 2q1 0 1.7 0.7t0.7 1.7v8.1q0 2.8-1.1 5.3t-2.9 4.3-4.3 2.9-5.2 1.1q-2.7 0-5.2-1.1t-4.3-2.9-2.9-4.3-1.1-5.2v-8.1q0-1 0.7-1.7t1.7-0.7h22zM13.5 18.6q0.7 0 1.3-0.5l6.3-6.1q0.6-0.5 0.6-1.3 0-0.8-0.5-1.3t-1.3-0.5q-0.7 0-1.3 0.5l-5 4.8-5-4.8q-0.5-0.5-1.3-0.5-0.8 0-1.3 0.5t-0.5 1.3q0 0.8 0.6 1.3l6.3 6.1q0.5 0.5 1.3 0.5z"/></svg></span><span class="shariff-text">pocket</span>&nbsp;<span class="shariff-count" data-service="pocket" style="color:#ff0000;opacity:0"></span>&nbsp;</a></li><li class="shariff-button linkedin" style="background-color:#1488bf"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F&title=Firefox+57+from+an+NVDA+user%E2%80%99s+perspective" title="Share on LinkedIn" aria-label="Share on LinkedIn" role="button" rel="noopener nofollow" class="shariff-link" target="_blank" style="background-color:#0077b5; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 27 32"><path d="M6.2 11.2v17.7h-5.9v-17.7h5.9zM6.6 5.7q0 1.3-0.9 2.2t-2.4 0.9h0q-1.5 0-2.4-0.9t-0.9-2.2 0.9-2.2 2.4-0.9 2.4 0.9 0.9 2.2zM27.4 18.7v10.1h-5.9v-9.5q0-1.9-0.7-2.9t-2.3-1.1q-1.1 0-1.9 0.6t-1.2 1.5q-0.2 0.5-0.2 1.4v9.9h-5.9q0-7.1 0-11.6t0-5.3l0-0.9h5.9v2.6h0q0.4-0.6 0.7-1t1-0.9 1.6-0.8 2-0.3q3 0 4.9 2t1.9 6z"/></svg></span><span class="shariff-text">share</span>&nbsp;<span class="shariff-count" data-service="linkedin" style="color:#0077b5;opacity:0"></span>&nbsp;</a></li><li class="shariff-button xing" style="background-color:#29888a"><a href="https://www.xing.com/social_plugins/share?url=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" title="Share on Xing" aria-label="Share on Xing" role="button" rel="noopener nofollow" class="shariff-link" target="_blank" style="background-color:#126567; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 25 32"><path d="M10.7 11.9q-0.2 0.3-4.6 8.2-0.5 0.8-1.2 0.8h-4.3q-0.4 0-0.5-0.3t0-0.6l4.5-8q0 0 0 0l-2.9-5q-0.2-0.4 0-0.7 0.2-0.3 0.5-0.3h4.3q0.7 0 1.2 0.8zM25.1 0.4q0.2 0.3 0 0.7l-9.4 16.7 6 11q0.2 0.4 0 0.6-0.2 0.3-0.6 0.3h-4.3q-0.7 0-1.2-0.8l-6-11.1q0.3-0.6 9.5-16.8 0.4-0.8 1.2-0.8h4.3q0.4 0 0.5 0.3z"/></svg></span><span class="shariff-text">share</span>&nbsp;<span class="shariff-count" data-service="xing" style="color:#126567;opacity:0"></span>&nbsp;</a></li><li class="shariff-button mailto" style="background-color:#a8a8a8"><a href="mailto:?body=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F&subject=Firefox%2057%20from%20an%20NVDA%20user%E2%80%99s%20perspective" title="Send by email" aria-label="Send by email" role="button" rel="noopener nofollow" class="shariff-link" style="background-color:#999; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M32 12.7v14.2q0 1.2-0.8 2t-2 0.9h-26.3q-1.2 0-2-0.9t-0.8-2v-14.2q0.8 0.9 1.8 1.6 6.5 4.4 8.9 6.1 1 0.8 1.6 1.2t1.7 0.9 2 0.4h0.1q0.9 0 2-0.4t1.7-0.9 1.6-1.2q3-2.2 8.9-6.1 1-0.7 1.8-1.6zM32 7.4q0 1.4-0.9 2.7t-2.2 2.2q-6.7 4.7-8.4 5.8-0.2 0.1-0.7 0.5t-1 0.7-0.9 0.6-1.1 0.5-0.9 0.2h-0.1q-0.4 0-0.9-0.2t-1.1-0.5-0.9-0.6-1-0.7-0.7-0.5q-1.6-1.1-4.7-3.2t-3.6-2.6q-1.1-0.7-2.1-2t-1-2.5q0-1.4 0.7-2.3t2.1-0.9h26.3q1.2 0 2 0.8t0.9 2z"/></svg></span><span class="shariff-text">e-mail</span>&nbsp;</a></li><li class="shariff-button info" style="background-color:#eee"><a href="http://ct.de/-2467514" title="More information about these buttons." aria-label="More information about these buttons." role="button" rel="noopener nofollow" class="shariff-link" target="_blank" style="background-color:#fff; color:#fff"><span class="shariff-icon"><svg width="32px" height="20px" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 11 32" style="fill:#999"><path d="M11.4 24v2.3q0 0.5-0.3 0.8t-0.8 0.4h-9.1q-0.5 0-0.8-0.4t-0.4-0.8v-2.3q0-0.5 0.4-0.8t0.8-0.4h1.1v-6.8h-1.1q-0.5 0-0.8-0.4t-0.4-0.8v-2.3q0-0.5 0.4-0.8t0.8-0.4h6.8q0.5 0 0.8 0.4t0.4 0.8v10.3h1.1q0.5 0 0.8 0.4t0.3 0.8zM9.2 3.4v3.4q0 0.5-0.4 0.8t-0.8 0.4h-4.6q-0.4 0-0.8-0.4t-0.4-0.8v-3.4q0-0.4 0.4-0.8t0.8-0.4h4.6q0.5 0 0.8 0.4t0.4 0.8z"/></svg></span><span class="shariff-text">info</span>&nbsp;</a></li></ul></div>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="byline"><span class="author vcard"><img alt='' src='https://secure.gravatar.com/avatar/2ecd0aea5cef211156238051d93be74b?s=49&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/2ecd0aea5cef211156238051d93be74b?s=98&amp;d=mm&amp;r=g 2x' class='avatar avatar-49 photo' height='49' width='49' /><span class="screen-reader-text">Author </span> <a class="url fn n" href="https://www.marcozehe.de/author/blindfisch/">Marco</a></span></span><span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/" rel="bookmark"><time class="entry-date published" datetime="2017-11-07T15:57:28+00:00">11/07/2017</time><time class="updated" datetime="2017-11-07T15:58:00+00:00">11/07/2017</time></a></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.marcozehe.de/category/accessibility/" rel="category tag">Accessibility</a>, <a href="https://www.marcozehe.de/category/firefox/" rel="category tag">Firefox</a>, <a href="https://www.marcozehe.de/category/nvda/" rel="category tag">NVDA</a></span><span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://www.marcozehe.de/tag/accessibility/" rel="tag">Accessibility</a>, <a href="https://www.marcozehe.de/tag/firefox/" rel="tag">Firefox</a>, <a href="https://www.marcozehe.de/tag/nvda/" rel="tag">NVDA</a>, <a href="https://www.marcozehe.de/tag/quantum/" rel="tag">Quantum</a></span>			</footer><!-- .entry-footer -->
</article><!-- #post-## -->

<div id="comments" class="comments-area">

			<h2 class="comments-title">
			3 thoughts on &ldquo;Firefox 57 from an NVDA user&#8217;s perspective&rdquo;		</h2>

		
		<ol class="comment-list">
					<li id="comment-3916" class="comment even thread-even depth-1">
			<article id="div-comment-3916" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/8d4997e3ac2d1a6785b3d665709ac823?s=42&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8d4997e3ac2d1a6785b3d665709ac823?s=84&amp;d=mm&amp;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' />						<b class="fn"><a href='http://shafpatel.wordpress.com' rel='external nofollow' class='url'>Shaf Patel</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/#comment-3916">
							<time datetime="2017-11-07T16:33:37+00:00">
								11/07/2017 at 16:33							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Thank you for all of your incredible work.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/?replytocom=3916#respond' onclick='return addComment.moveForm( "div-comment-3916", "3916", "respond", "851" )' aria-label='Reply to Shaf Patel'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
		<li id="comment-3917" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-3917" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/e2d1802d4f72e27766192024cfb25dd0?s=42&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e2d1802d4f72e27766192024cfb25dd0?s=84&amp;d=mm&amp;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' />						<b class="fn"><a href='http://gravatar.com/neilosman' rel='external nofollow' class='url'>Neil Osman</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/#comment-3917">
							<time datetime="2017-11-07T16:54:39+00:00">
								11/07/2017 at 16:54							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>not published yet <a href="https://support.mozilla.org/en-US/kb/can-i-use-my-screen-reader-new-firefox" rel="nofollow">https://support.mozilla.org/en-US/kb/can-i-use-my-screen-reader-new-firefox</a></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/?replytocom=3917#respond' onclick='return addComment.moveForm( "div-comment-3917", "3917", "respond", "851" )' aria-label='Reply to Neil Osman'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
		<li id="comment-3918" class="comment even thread-even depth-1">
			<article id="div-comment-3918" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/83010b6ef5076436b9ce0bedaf8038d9?s=42&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/83010b6ef5076436b9ce0bedaf8038d9?s=84&amp;d=mm&amp;r=g 2x' class='avatar avatar-42 photo' height='42' width='42' />						<b class="fn"><a href='https://www.blindtec.com.br' rel='external nofollow' class='url'>Marlon</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/#comment-3918">
							<time datetime="2017-11-07T17:23:44+00:00">
								11/07/2017 at 17:23							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Marco,</p>
<p>I know that this is not the blog objective but I am extremely curious to know how do you plan to take performance back in a some what technical way &#8230; because the way I understand it screen readers are slow on ff 57 because the browser now uses multi process rendering and thus can not easily feed the screen reader virtual buffer in a progressive way like it did before, making the screen reader wait for the whole thing to be complete before the buffer is finally feed.<br />
This plus the fact, and I am not completely sure, that injection is no longer allowed to happen making ipc the only alternative and slowingg the comunication between these two parts.</p>
<p>This being what happens, I can not see how you would increase back thhe performance unless virtual buffers are no longer used but I don&#8217;t think this will happen soon. Further more, this would be a NVDA release not a FireFox release. How are you going to take performance bback to the expected levels on this new architecture? Curious &#8230;</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/?replytocom=3918#respond' onclick='return addComment.moveForm( "div-comment-3918", "3918", "respond", "851" )' aria-label='Reply to Marlon'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

		
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">What are your thoughts?					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/11/07/firefox-57-nvda-users-perspective/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=4273928&#038;postid=851&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=What+are+your+thoughts%3F&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.4&#038;sig=430b774bc9419e27f09f9fbbe41ce5aaafdf369f#parent=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- .comments-area -->

	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.marcozehe.de/2017/09/29/rethinking-web-accessibility-on-windows/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Rethinking Web Accessibility On Windows</span></a></div></div>
	</nav>
	</main><!-- .site-main -->

	
</div><!-- .content-area -->


	<aside id="secondary" class="sidebar widget-area" role="complementary">
		<section id="search-2" class="widget widget_search">
<form role="search" method="get" class="search-form" action="https://www.marcozehe.de/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
	</label>
	<button type="submit" class="search-submit"><span class="screen-reader-text">Search</span></button>
</form>
</section>		<section id="recent-posts-2" class="widget widget_recent_entries">		<h2 class="widget-title">Recent Posts</h2>		<ul>
					<li>
				<a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/">Firefox 57 from an NVDA user&#8217;s perspective</a>
						</li>
					<li>
				<a href="https://www.marcozehe.de/2017/09/29/rethinking-web-accessibility-on-windows/">Rethinking Web Accessibility On Windows</a>
						</li>
					<li>
				<a href="https://www.marcozehe.de/2017/08/30/firefox-57-will-less-chatty-screen-readers-situations/">Firefox 57 will be less chatty to screen readers in some situations</a>
						</li>
					<li>
				<a href="https://www.marcozehe.de/2016/11/23/javascript-not-enemy-accessibility/">JavaScript is not an enemy of accessibility!</a>
						</li>
					<li>
				<a href="https://www.marcozehe.de/2016/10/05/firefox-49-supports-the-html5-details-and-summary-elements/">Firefox 49 supports the HTML5 &lt;details&gt; and &lt;summary&gt; elements</a>
						</li>
				</ul>
		</section>		<section id="recent-comments-2" class="widget widget_recent_comments"><h2 class="widget-title">Recent Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://www.blindtec.com.br' rel='external nofollow' class='url'>Marlon</a></span> on <a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/#comment-3918">Firefox 57 from an NVDA user&#8217;s perspective</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://gravatar.com/neilosman' rel='external nofollow' class='url'>Neil Osman</a></span> on <a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/#comment-3917">Firefox 57 from an NVDA user&#8217;s perspective</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://shafpatel.wordpress.com' rel='external nofollow' class='url'>Shaf Patel</a></span> on <a href="https://www.marcozehe.de/2017/11/07/firefox-57-nvda-users-perspective/#comment-3916">Firefox 57 from an NVDA user&#8217;s perspective</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://make.wordpress.org/updates/2017/10/24/accessibility-update-for-october-23-2017/' rel='external nofollow' class='url'>Accessibility update for October 23, 2017 &#8211; Team Updates &mdash; WordPress</a></span> on <a href="https://www.marcozehe.de/2017/08/30/firefox-57-will-less-chatty-screen-readers-situations/#comment-3903">Firefox 57 will be less chatty to screen readers in some situations</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://ulrich.pogson.ch' rel='external nofollow' class='url'>Ulrich</a></span> on <a href="https://www.marcozehe.de/2017/08/30/firefox-57-will-less-chatty-screen-readers-situations/#comment-3902">Firefox 57 will be less chatty to screen readers in some situations</a></li></ul></section><section id="archives-2" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<ul>
			<li><a href='https://www.marcozehe.de/2017/11/'>November 2017</a></li>
	<li><a href='https://www.marcozehe.de/2017/09/'>September 2017</a></li>
	<li><a href='https://www.marcozehe.de/2017/08/'>August 2017</a></li>
	<li><a href='https://www.marcozehe.de/2016/11/'>November 2016</a></li>
	<li><a href='https://www.marcozehe.de/2016/10/'>October 2016</a></li>
	<li><a href='https://www.marcozehe.de/2016/05/'>May 2016</a></li>
	<li><a href='https://www.marcozehe.de/2016/03/'>March 2016</a></li>
	<li><a href='https://www.marcozehe.de/2016/02/'>February 2016</a></li>
	<li><a href='https://www.marcozehe.de/2016/01/'>January 2016</a></li>
	<li><a href='https://www.marcozehe.de/2015/12/'>December 2015</a></li>
	<li><a href='https://www.marcozehe.de/2015/11/'>November 2015</a></li>
	<li><a href='https://www.marcozehe.de/2015/08/'>August 2015</a></li>
	<li><a href='https://www.marcozehe.de/2015/06/'>June 2015</a></li>
	<li><a href='https://www.marcozehe.de/2015/04/'>April 2015</a></li>
	<li><a href='https://www.marcozehe.de/2015/02/'>February 2015</a></li>
	<li><a href='https://www.marcozehe.de/2015/01/'>January 2015</a></li>
	<li><a href='https://www.marcozehe.de/2014/10/'>October 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/09/'>September 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/08/'>August 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/07/'>July 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/05/'>May 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/04/'>April 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/03/'>March 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/02/'>February 2014</a></li>
	<li><a href='https://www.marcozehe.de/2014/01/'>January 2014</a></li>
	<li><a href='https://www.marcozehe.de/2013/11/'>November 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/09/'>September 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/08/'>August 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/07/'>July 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/06/'>June 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/05/'>May 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/04/'>April 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/03/'>March 2013</a></li>
	<li><a href='https://www.marcozehe.de/2013/02/'>February 2013</a></li>
	<li><a href='https://www.marcozehe.de/2012/12/'>December 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/11/'>November 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/10/'>October 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/08/'>August 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/07/'>July 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/06/'>June 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/05/'>May 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/04/'>April 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/02/'>February 2012</a></li>
	<li><a href='https://www.marcozehe.de/2012/01/'>January 2012</a></li>
	<li><a href='https://www.marcozehe.de/2011/12/'>December 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/11/'>November 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/10/'>October 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/09/'>September 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/06/'>June 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/05/'>May 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/04/'>April 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/03/'>March 2011</a></li>
	<li><a href='https://www.marcozehe.de/2011/02/'>February 2011</a></li>
	<li><a href='https://www.marcozehe.de/2010/11/'>November 2010</a></li>
	<li><a href='https://www.marcozehe.de/2010/10/'>October 2010</a></li>
	<li><a href='https://www.marcozehe.de/2010/09/'>September 2010</a></li>
	<li><a href='https://www.marcozehe.de/2010/06/'>June 2010</a></li>
	<li><a href='https://www.marcozehe.de/2010/05/'>May 2010</a></li>
	<li><a href='https://www.marcozehe.de/2010/03/'>March 2010</a></li>
	<li><a href='https://www.marcozehe.de/2010/02/'>February 2010</a></li>
	<li><a href='https://www.marcozehe.de/2009/11/'>November 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/10/'>October 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/09/'>September 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/08/'>August 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/07/'>July 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/06/'>June 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/05/'>May 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/04/'>April 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/03/'>March 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/02/'>February 2009</a></li>
	<li><a href='https://www.marcozehe.de/2009/01/'>January 2009</a></li>
	<li><a href='https://www.marcozehe.de/2008/12/'>December 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/11/'>November 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/10/'>October 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/09/'>September 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/08/'>August 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/07/'>July 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/06/'>June 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/05/'>May 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/04/'>April 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/03/'>March 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/02/'>February 2008</a></li>
	<li><a href='https://www.marcozehe.de/2008/01/'>January 2008</a></li>
	<li><a href='https://www.marcozehe.de/2007/12/'>December 2007</a></li>
	<li><a href='https://www.marcozehe.de/2007/11/'>November 2007</a></li>
		</ul>
		</section><section id="categories-2" class="widget widget_categories"><h2 class="widget-title">Categories</h2>		<ul>
	<li class="cat-item cat-item-2"><a href="https://www.marcozehe.de/category/accessibility/" >Accessibility</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://www.marcozehe.de/category/allgemein/" >Allgemein</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://www.marcozehe.de/category/apple/" >Apple</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://www.marcozehe.de/category/aria/" >ARIA</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://www.marcozehe.de/category/extensions/" >Extensions</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://www.marcozehe.de/category/firefox/" >Firefox</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://www.marcozehe.de/category/firefoxos/" >FirefoxOS</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://www.marcozehe.de/category/general/" >General</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://www.marcozehe.de/category/gmail/" >GMail</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://www.marcozehe.de/category/mobile/" >Mobile</a>
</li>
	<li class="cat-item cat-item-11"><a href="https://www.marcozehe.de/category/mozilla/" >Mozilla</a>
</li>
	<li class="cat-item cat-item-12"><a href="https://www.marcozehe.de/category/nvda/" >NVDA</a>
</li>
	<li class="cat-item cat-item-13"><a href="https://www.marcozehe.de/category/orca/" >Orca</a>
</li>
	<li class="cat-item cat-item-14"><a href="https://www.marcozehe.de/category/qa/" >QA</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://www.marcozehe.de/category/seamonkey/" >SeaMonkey</a>
</li>
	<li class="cat-item cat-item-16"><a href="https://www.marcozehe.de/category/testing/" >Testing</a>
</li>
	<li class="cat-item cat-item-17"><a href="https://www.marcozehe.de/category/thunderbird/" >Thunderbird</a>
</li>
	<li class="cat-item cat-item-18"><a href="https://www.marcozehe.de/category/uncategorized/" >Uncategorized</a>
</li>
	<li class="cat-item cat-item-19"><a href="https://www.marcozehe.de/category/windows/" >Windows</a>
</li>
	<li class="cat-item cat-item-20"><a href="https://www.marcozehe.de/category/wordpress/" >WordPress</a>
</li>
	<li class="cat-item cat-item-21"><a href="https://www.marcozehe.de/category/yahoo/" >Yahoo!</a>
</li>
		</ul>
</section><section id="meta-2" class="widget widget_meta"><h2 class="widget-title">Meta</h2>			<ul>
						<li><a rel="nofollow" href="https://www.marcozehe.de/wp-login.php">Log in</a></li>
			<li><a href="https://www.marcozehe.de/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://www.marcozehe.de/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</section>	</aside><!-- .sidebar .widget-area -->

		</div><!-- .site-content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
							<nav class="main-navigation" role="navigation" aria-label="Footer Primary Menu">
					<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="primary-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-789"><a href="https://www.marcozehe.de/category/firefox/">Firefox</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-790"><a href="https://www.marcozehe.de/category/aria/">ARIA</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-791"><a href="https://www.marcozehe.de/category/mozilla/">Mozilla</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-792"><a href="https://www.marcozehe.de/category/mobile/">Mobile</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-793"><a href="https://www.marcozehe.de/category/apple/">Apple</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-794"><a href="https://www.marcozehe.de/category/nvda/">NVDA</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-795"><a href="https://www.marcozehe.de/web-accessibility-resources/">Web Accessibility Resources</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-796"><a href="https://www.marcozehe.de/articles/how-to-use-nvda-and-firefox-to-test-your-web-pages-for-accessibility/">How to use NVDA and Firefox to test your web pages for accessibility</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-797"><a href="https://www.marcozehe.de/about/">About</a></li>
</ul></div>				</nav><!-- .main-navigation -->
			
			
			<div class="site-info">
								<span class="site-title"><a href="https://www.marcozehe.de/" rel="home">Marco&#039;s Accessibility Blog</a></span>
				<a href="https://wordpress.org/">Proudly powered by WordPress</a>
			</div><!-- .site-info -->
		</footer><!-- .site-footer -->
	</div><!-- .site-inner -->
</div><!-- .site -->

	<div style="display:none">
	<div class="grofile-hash-map-2ecd0aea5cef211156238051d93be74b">
	</div>
	<div class="grofile-hash-map-8d4997e3ac2d1a6785b3d665709ac823">
	</div>
	<div class="grofile-hash-map-e2d1802d4f72e27766192024cfb25dd0">
	</div>
	<div class="grofile-hash-map-83010b6ef5076436b9ce0bedaf8038d9">
	</div>
	</div>
<link rel='stylesheet' id='shariffcss-css'  href='https://www.marcozehe.de/wp-content/plugins/shariff/css/shariff.min.css?ver=4.3.0' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201745'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.marcozehe.de/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://www.marcozehe.de/wp-content/themes/twentysixteen/js/skip-link-focus-fix.js?ver=20160816'></script>
<script type='text/javascript' src='https://www.marcozehe.de/wp-includes/js/comment-reply.min.js?ver=4.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.marcozehe.de/wp-content/themes/twentysixteen/js/functions.js?ver=20160816'></script>
<script type='text/javascript' src='https://www.marcozehe.de/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://www.marcozehe.de/wp-content/plugins/shariff/js/shariff.min.js?ver=4.3.0'></script>
<script async="async" type='text/javascript' src='https://www.marcozehe.de/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=4273928&postid=851&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=What+are+your+thoughts%3F&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.4&sig=430b774bc9419e27f09f9fbbe41ce5aaafdf369f#parent=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=4273928&postid=851&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=What+are+your+thoughts%3F&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.4&sig=430b774bc9419e27f09f9fbbe41ce5aaafdf369f#parent=https%3A%2F%2Fwww.marcozehe.de%2F2017%2F11%2F07%2Ffirefox-57-nvda-users-perspective%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201745.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.4',blog:'4273928',post:'851',tz:'1',srv:'www.marcozehe.de'} ]);
	_stq.push([ 'clickTrackerInit', '4273928', '851' ]);
</script>
</body>
</html>
